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What is CodePrint?

CodePrint ä is a Windows 3.1 compatible program for printing ASCII text files on any printer 
supported by Windows. What makes CodePrint unique is you have control over how the text 
is formatted on the page. You can open and save configurations that store the page 
formatting for the various text files that you normally print. For example, if you are a 
programmer you can save a configuration for printing your source code two-up on a page. 
Users of on-line services can save a configuration for printing README files or ON-LINE 
service listings. To save the amount of paper used, CodePrint has a duplex printing option 
that allows printing on both sides of the paper. Features include:

· Portrait or Landscape paper orientation
· Multiple columns
· Include headers and/or footers that you define including

filename, date and page number
· Change fonts, style and size
· Include border with column dividers or dividers ONLY
· Change left, top, right and bottom margin
· Change the spacing used to expand tabs
· Text automatically wraps if wider than column
· Change wrap symbol and turn ON or OFF
· Option to truncate lines at the right margin
· Option to include line numbers
· Open and save page setups
· Compatible with Windows 3.1 Drag-Drop feature using

File Manager
· Duplex printing option - print on both sides of the paper
· Multiple instances of CodePrint allow you to drop files to

several different configurations

The Drag-Drop feature under Windows 3.1 allows you to select files from the File Manager 
and Drag and then Drop them over the CodePrint icon for printing.



Benefits of Registering

CodePrint is distributed as shareware and you must therefore register the software if you 
continue to use the program beyond the 21 day evaluation period. When you register 
CodePrint you will receive the following benefits.

· Latest version of the software on disk
· On-line support from Compuserve or written support by mail
· Notification of low-cost upgrades
· Registration information to remove information screen during program start-up

If you use CodePrint print, please register by filling out the registration form and sending in 
your registration fee.

Related Topics
Upgrade Information



Upgrade Information

Upgrades for CodePrint will be handled in the following manner. The three upgrade 
classifications are as follows.

1 Bug fixes ONLY Increments version number in
the x position as in 2.1x

2 Minor 
enhancements 
w/possible bug 
fixes

Increments version number in
the x position as in 2.x0

3 Major 
enhancements 
w/possible bug 
fixes

Increments version number in
the x position as in x.00

Class 1 upgrades are always free to registered users by downloading    the shareware 
version from one of many locations. If you have version 2.00 or higher, your current 
registration number will convert the shareware version to a registered version. If you have 
problems, please contact us. (See contact information below)

Class 2 upgrades are usually free as well. They can be downloaded in the same manner as 
class 1 upgrades. However, there may be occasions were a small fee is required for shipping
and handling of a new disk. This fee will be between $3-$5.

Upgrade notices will be sent for class 3 upgrades. Class 3 upgrades will require a small 
upgrade fee. If you decide to upgrade you would simply return the form with your upgrade 
fee. You will then receive a new disk of the latest version.

Download Locations:
Current versions of CodePrint can always be found in the following locations.

Compuserve GO WINADV (lib 16)
GO BCPPWIN (lib 5)
GO ZNT:WINSOURCES (lib 3)

America 
Online

Windows:Utilities

These locations are subject to changes by the individual on-line service.

Contact Information:
If you have any questions and need to contact us, please send e-mail using one of the 
following on-line services or you may write us at the address below.

Compuserve ID: 72230,47

America 
Online

ID: CGPARKER

Mailing 
Address

Micro Software 
Solutions
PO Box 851504
Richardson, TX 75085
USA



Upgrade Schedule:
Class 1 versions are uploaded to the on-line services listed above as required. Class 2 
versions are uploaded about every 2-3 months. Class 3 versions are released about every 6-
10 months. Thank you for your support.



File Menu

The File menu includes commands that allow you to open and save page configurations, 
change printer settings and exit CodePrint.

For more information, select the File menu command.

Open Configuration Open the DEFAULTS or user saved configurations.
Save Save the current configuration.
Save As Save as a new configuration.
Printer Setup Change printer settings.
Exit Exit CodePrint.



Page Menu

The Page menu includes commands that allow you to change the current font, header and 
footer text and page layout options.

For more information, select the Page menu command.

Font Change font.
Header/FooterChange header and footer text.
Layout Change page layout.
Info Display page information summary.



Options Menu

The Options menu includes commands that allow you to change the way CodePrint operates.

For more information, select the Options menu command.

Use Path Toggles Use Path option.
Ignore Form Feeds Toggles Ignore Form Feed option.
Truncate Lines Toggles Truncate Lines option.
Duplex Printing Toggles Duplex Printing option.



Help Menu

The Help menu includes commands that allow you to display help for various topics related 
to CodePrint.

For more information, select the Help menu command name.

Contents
Search
About CodePrint



Control Menu

The Control menu, duplicates the most used commands as well as providing support for 
duplex printing. The following commands are only available from the Control menu by 
selecting the Application icon.

Open Configuration
Info
Duplex Printing
Print Pass 2
Cancel Pass 2



List Command

The List push button on the main CodePrint window is used to populate the file list box with 
files in the current directory that match the wild card specification in the File spec. edit 
control. Therefore, if a file name is entered or displayed in this field, by selecting a file name 
from the file list box, the List push button is disabled.



Select File(s) Command

The Select push button on the main CodePrint window is used to populate the print list box 
with the selection in the File spec. edit control. If the file spec. control contains a file name, 
the file name will be displayed in the print list box. If the file spec. control contains a wild 
card specification such as *.txt, all the files in the current directory with a TXT extension are 
displayed in the print list box. If the file spec. edit control is blank, the Select push button is 
disabled.



Print File(s) Command

The Print Files push button on the main CodePrint window is used to print all the files listed 
in the print list box located directly under the button. If the print list box is empty, this 
button is disabled.

Related Topics
Duplex Printing



Remove Command

The Remove push button on the main CodePrint window is used to delete the file entry 
selected in the print list box. If the print list box is empty, this button is disabled.



Clear All Command

The Clear All push button on the main CodePrint window is used to delete all the file entries 
displayed in the print list box. If the print list box is empty, this button is disabled.



Opening a Configuration

To change the current configuration, select Open Configuration from the File menu or click 
the Open button on the toolbar, to display the Open Configuration dialog. The first 
configuration is always DEFAULTS. Other saved configurations are listed below DEFAULTS.

To load a configuration, highlight the configuration you want to open and press OK or double-
click the highlighted line using the left mouse button. The selected configuration is now the 
current one with the configuration name displayed in the caption bar.



Saving Current Configuration

To save the current configuration, select Save from the File menu. This option is GRAYED if 
no changes have been made. Alternately you can click the Save button on the toolbar.

The following information is saved with each configuration.

· Page specific - number of columns, margins, spacing for tabs,
line number status, border, orientation and wrap symbol

· Font specific - size, style and type face
· Header specific - header text
· Footer specific - footer text
· Options status
· General - file spec., directory path and window position



Saving As a New Configuration

To save the current configuration with a new name, select Save As from the File menu to 
display the Save As dialog. The current configuration name is displayed in the edit control.

To save the current configuration using the current name, press OK. To save the current 
configuration under a new name, type the new configuration name and press OK.

The following information is saved with each configuration.

· Page specific - number of columns, margins, spacing for tabs,
line number status, border, orientation and wrap symbol

· Font specific - size, style and type face
· Header specific - header text
· Footer specific - footer text
· General - file spec., directory path and window position



Changing Printer Setup

To change various printer options such as orientation or paper tray option, select Printer 
Setup from the File menu. If you only want to change the paper orientation, select the 
Layout command from the Page menu to change this feature.



Changing Fonts

To change the current font, select Fonts from the Page menu to display the Font dialog. This 
is the font common dialog new to Windows 3.1.

Changing font, style or size affects both the page text and the header/footer text.



Changing Header/Footer

To change the header and/or footer text, select Header/Footer from the Page menu to display
the Header/Footer dialog. You can enter any text you want for either the header or footer. To 
access the file name, date/time or the page number you can press the appropriate push 
button along the bottom of the dialog, which will insert the formatting characters at the 
location of the I-beam cursor. For example, to produce the following footer

c:\files\readme\readme.txt - page 1

enter the following footer text in the footer edit control.

%f - page %p

Where %f inserts the file name and %p inserts the current page number.

For the header or footer to be printed, the header and footer check boxes must be checked. 
The middle and right status fields, located below Columns, displays the current status of the 
header and footer respectively. If "On" is displayed, the option is ON, while "Off" means 
disabled.



Changing Page Layout

To change the page layout options, select Layout from the Page menu to display the page 
layout dialog. From the page layout dialog you can change or toggle the following page 
features.

· Number of text columns per page
· The spacing used to expand tabs
· Enable printing a line wrap symbol
· Enable or disable line numbers
· The amount, in inches, for the left, top, right and bottom margins
· Page border with column dividers, column dividers only or no border

or column dividers
· Page orientation which can be landscape or portrait

The status of the line number option is displayed to the right of Columns. The header, footer 
and border status are displayed below Columns. If "On" is displayed the option is ON, while 
"Off" indicates the option is disabled.



Drag and Drop Printing

CodePrint takes advantage of the new Drag-and-Drop feature of Windows 3.1. CodePrint 
must be minimized to use Drag-and-Drop. To use the drag-and-drop feature, open File 
Manager and select the text file(s) you want to print. Then drag the files over the CodePrint 
icon and release the mouse button.

Related Topics
Using Multiple Instances of CodePrint



Duplex Printing

Duplex printing allows you to save paper by printing on both sides of the paper. To use the 
duplex printing option you must enable this feature by selecting Duplex Printing from the 
Options menu.

RESTORED MODE

Duplex printing requires two steps. First you select the files you want to print and choose the
Print File(s) button. After the files are sent to the printer or to Print Manager, the following 
message is displayed.

When printing is complete, turn sheets over and re-insert
in printer so the blank-side of the first sheet is on the
top. Then choose the Print File(s) button again.

Press OK. The files you printed will remain in the Print list box. Next, wait until all the sheets 
are placed in the output tray. Then place the sheets back in the printer's input tray and 
choose the Print File(s) button again to print on the back of the page as required. This 
completes duplex printing.

MINIMIZED MODE

There is only a slightly different procedure to follow when CodePrint is minimized. After 
dragging the file(s) to the Application icon the following message is displayed.

When printing is complete, turn sheets over and re-insert
in printer so the blank-side of the first sheet is on the
top. Then choose Print Pass 2 from Control Menu.

Press OK. The icon now displays a RED light on the right side of the printer. This is an 
indication the pass 2 is pending. When pass 1 printing is complete, and with CodePrint still 
minimized select the application icon to display the Control menu. Now select Print Pass 2 
to complete duplex printing. The printer light on the icon changes back to BLACK. If you 
need to cancel Pass 2 printing select Cancel Pass 2 from the Control menu.

Due to the variety of printers on the market, you may have to experiment with the order the 
sheets are output from the printer and the order and orientation required when placed back 
in the input tray. Therefore it is suggested that you print only one file with multiple sheets 
for test
purposes.

Related Topics
Sheet Order
Duplex Printing Option Command
Control Menu



Sheet Order

When duplex printing is enabled, you must pay attention to the order the sheets are placed 
in the output tray after the first printing pass and also the order they are placed back in the 
input tray for the second printing pass.

The output tray order should be as follows.

You should then turn the sheets over and place them back in the input tray as follows for the
second printing pass.

You may need to experiment to get the front to back orientation you require. For example, 
try rotating the pages 180 degrees.



Using the Toolbar

The toolbar, displayed below the menu bar, provides quick access to various commands.

Opens a configuration.

Saves the current configuration.

Displays the font dialog.

Displays the header/footer dialog.

Displays the page layout dialog.

The two status fields to the right of the buttons display the size, in bytes, and the date last 
modified for the file selected in the file list box. Initially these fields are blank and will not 
display information until a file is selected in the file list box.



Using Multiple Instances of CodePrint

CodePrint supports multiple instances. Why would you want to do this? The obvious reason 
is with the Drag-and-Drop feature new to Windows version 3.1.

As an example suppose you normally switch between two different configurations. One 
prints two-up in landscape mode, the other prints one-up in portrait mode. To use this 
feature open the first copy, which is set to use the two-up configuration and minimize it. 
Now open a second instance and minimize it. Select the Application icon to access the 
Control menu. Select Open Configuration to open the one-up configuration.

Now when you want to print files using the two-up configuration simply drop them on that 
icon. To print one-up drop the files on the other icon.

Related Topics
Opening a Configuration
Drag and Drop Printing
Duplex Printing



Glossary

application icon
configuration
control menu
DEFAULTS
edit control
multiple instance
registered user
shareware version



Open Configuration Command

Use this command to change the current configuration. Select Open from the File menu to 
display the Open Configuration dialog. The first configuration is always DEFAULTS. Other 
saved configurations are listed below DEFAULTS.

To load a configuration, highlight the configuration you want to open and press OK. The new  
configuration name is displayed in the caption bar.



Save Command

Use this command to save the current configuration. This command is initially GRAYED. If 
changes are made to the current configuration the Save command is enabled.

For a visual indication of when changes have been made, the window title displays an '*' 
between the application name and the configuration name as shown.

CodePrint * [Readme]

After changes are saved by selecting Save from the File menu or clicking the Save button on 
the toolbar, the title bar changes as shown.

CodePrint - [Readme]

To save the current configuration under a new name select Save As from the File menu.

The following information is saved with each configuration.

· Page specific - number of columns, margins, spacing for tabs,
line number status, border, orientation and wrap symbol

· Font specific - size, style and type face
· Header specific - header text
· Footer specific - footer text
· Options status
· General - file spec. and directory path



Save As Command

Use this command to save the current configuration with a new name. Select Save As from 
the File menu to display the Save As dialog.

The following information is saved for each configuration.

· Page specific - number of columns, margins, spacing for tabs,
line number status, border, orientation and wrap symbol

· Font specific - size, style and type face
· Header specific - header text
· Footer specific - footer text
· Options status
· General - file spec. and directory path



Printer Setup Command

Use this command to change various printer options. Select Printer Setup from the File menu
to display the Printer Setup dialog. You can change printer options such as default printer, 
paper size and paper source.



Exit Command

Select Exit to close CodePrint.



Font Command

Use this command to change the current font used for printing. Select Font from the Page 
menu to display the Font dialog. Changing the font, style or size changes both the page text 
and the header and footer text.



Header/Footer Command

Use this command to change the header and/or footer text. Select Header/Footer from the 
Page menu to display the Header/Footer dialog. You have the option to include or not include
header and footer text. You can enter any text and optionally include format codes to insert 
the File Name, Date/Time or Page number in the header or footer.



Page Layout Command

Use this command to change the page layout options. Select Layout from the Page menu to 
display the Page Layout dialog. From the Page Layout dialog you can change number of 
columns on a page, the number of spaces used to expand tabs,    toggle printing of the line 
wrap symbol or change symbol, toggle printing line numbers, toggle printing without or with 
a border with column dividers or column dividers only, change paper orientation, and 
change the left, top, right and bottom margin.



Page Info Command

Use this command to display summary information for the current configuration. Information
displayed in this dialog supplements information not displayed on the toolbar or status 
sections of the main window.

The following summary information is shown.

· Characters per line and lines per page
· Current status of Option menu items
· Current margin settings



Use Path Option Command

Use this command to toggle the option to use the path saved with a configuration. When this
option is checked, CodePrint will use the path and file spec. saved with the current 
configuration as the working directory during startup and when a saved configuration is 
opened.

If this option is not checked, CodePrint will use the default working directory, as listed in the 
Program Managers "Program Item Properties" dialog for the CodePrint icon item, during 
startup and when a saved configuration is opened.



Ignore Form Feeds Option Command

Use this command to toggle the option to ignore form feed characters. When this option is 
checked, CodePrint will ignore form feed characters within a text file.

If this option is not checked, CodePrint recognize form feed characters by advancing to the 
next page.



Truncate Lines Option Command

Use this command to toggle the option to truncate text printed on the page. When this 
option is checked, all lines are truncated if wider than the page.

If this option is not checked (default), all lines wider than the page will wrap to the next line.



Duplex Printing Option Command

Use this command to toggle the option to enable duplex printing. When this option is 
checked, CodePrint will print on both sides of the paper.

If this option is not checked (default), only one side of the paper is used. This option should 
be used when printing to network printers.

Related Topics
Duplex Printing



Help Contents Command

Use this command to display the help index for CodePrint.



Help Search Command

Use this command to display the help search dialog for locating specific help topics. 



Help About CodePrint Command

Use this command to display the about dialog for CodePrint. This dialog contains copyright 
information, version number, current Windows mode and Windows resource information.



Open Configuration Command

The Open Configuration command on the Control menu displays the Open Configuration 
dialog from the Application icon. This command is only accessible from the Application Icon.

Related Topics
Opening a Configuration



Info Command

The Info command on the Control menu displays the summary information dialog. This 
command is only accessible from the Application icon.

Related Topics
Info



Duplex Printing Command

The Duplex Printing command on the Control menu toggles the option to enable duplex 
printing. This command is only accessible from the Application icon.

Related Topics
Duplex Printing



Print Pass 2 Command

The Print Pass 2 command on the Control menu starts pass 2 when duplex printing is 
enabled. This item is grayed until after one or more files are dropped on the application icon.
This command is only accessible from the Application icon.



Cancel Pass 2 Command

The Cancel Pass 2 command on the Control menu cancels pass 2 of duplex printing. This 
item is grayed until one or more files are dropped on the application icon. This command is 
only accessible from the Application icon.



Page Layout Dialog

The Page Layout dialog allows you to change the number of columns on a page, the number 
of spaces used to expand tabs, toggle printing line numbers, toggle printing without or with 
a border with column dividers, change paper orientation, and change the left, top, right and 
bottom margin.

The following chart list the DEFAULTS settings.

Column
s

Tab
Wrap
Status

Wrap
Symbol LN Border

1 8 ON ===> OFF BORDER

Orientation Left Top Right Botto
m

PORTRAIT 0.05" 0.05" 0.05" 0.05"

If you are using a dot matrix printer and the right or bottom margins are off the page, you 
may want to change the margins as follows.

Left Top Right Botto
m

0.10" 0.30" 0.10" 0.30"

You may have to experiment to find the margin settings that work correctly with your printer.





Contents

 The Contents contains a list of all Help topics available for CodePrint. For information on 
how to use Help, press F1 or choose Using Help from the Help menu.



Application icon

A graphic that represents a running application. This icon appears only after you start an 
application and then minimize (reduce) it.



Configuration

A configuration stores program options. You can therefore change settings such as the font 
and font size and save this information under various names. The default configuration is 
always available if you want to load the application defaults.



Control Menu

This menu, also known as the System menu, contains commands you use to manipulate a 
window. The control menu is also available when an application is minimized to an icon. To 
access the control menu click on the box located next to the title bar of the window or select
the application icon when minimized.



Default

The DEFAULTS configuration retains the settings as shipped.



Edit Control

A edit control is a field for retrieving information from the user that is required by the 
application program.



Multiple Instance

Multiple instance refers to running more than one copy of an application.



Registered Users

A registered user is a thoughtful person who paid the required fee to register CodePrint. As a
registered user you are entitled to various benefits such as free support and notification of 
upgrades.



Shareware Version

A shareware version of CodePrint displays 2 opening NAG screens when the program is first 
loaded. Once the software is properly registered, these screens will no longer appear.






